<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en">

<head>
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<script type="text/javascript" src="//hi.districtm.ca/v3.0.103387.js"></script>
<script type="text/javascript" src="//hi.districtm.ca/currency.js"></script>
<script type="text/javascript" src="//cdn.districtm.ca/v4.1.header.min.js"></script>
  <title>WWE Wrestling News, Rumors, Results & Spoilers | Rajah.com  Live WWE RAW Results Now In Progress (4/24): Last RAW Before Payback!</title>
  <meta http-equiv="Content-Style-Type" content="text/css" />
  <meta NAME="keywords" CONTENT="wrestling, rajah, wrestling news, wwe rumors, wwe news, live PPV results, Raw, Smackdown, spoilers, PPV" />
  <meta name="description" content="Backstage WWE news, rumors, results & spoilers including live WWE PPV results"/>
  <meta name="robots" content="NOODP" />
  <meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<link rel="shortcut icon" href="/files/rajah_favicon.jpg" type="image/x-icon" />
  <link type="text/css" rel="stylesheet" media="all" href="/modules/node/node.css?J" />
<link type="text/css" rel="stylesheet" media="all" href="/modules/poll/poll.css?J" />
<link type="text/css" rel="stylesheet" media="all" href="/modules/system/defaults.css?J" />
<link type="text/css" rel="stylesheet" media="all" href="/modules/system/system.css?J" />
<link type="text/css" rel="stylesheet" media="all" href="/modules/system/system-menus.css?J" />
<link type="text/css" rel="stylesheet" media="all" href="/modules/user/user.css?J" />
<link type="text/css" rel="stylesheet" media="all" href="/themes/rajah/style.css?J" />
<script type='text/javascript' src='http://partner.googleadservices.com/gampad/google_service.js'>
</script>

<meta name="google-site-verification" content="j1Dx1Eo3RIudvhpqMZyPk0Efr7VFRs2hjvIVNNDNKHs" />

<script type='text/javascript'>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
  (function() {
    var gads = document.createElement('script');
    gads.async = true;
    gads.type = 'text/javascript';
    var useSSL = 'https:' == document.location.protocol;
    gads.src = (useSSL ? 'https:' : 'http:') +
      '//www.googletagservices.com/tag/js/gpt.js';
    var node = document.getElementsByTagName('script')[0];
    node.parentNode.insertBefore(gads, node);
  })();
</script>

<script type='text/javascript'>
  googletag.cmd.push(function() {
    googletag.defineSlot('/3695761/160x600', [160, 600], 'div-gpt-ad-1430638724272-0').addService(googletag.pubads());
    googletag.defineSlot('/3695761/160x600_2', [160, 600], 'div-gpt-ad-1430638724272-1').addService(googletag.pubads());
    googletag.defineSlot('/3695761/300x250', [300, 250], 'div-gpt-ad-1430638724272-2').addService(googletag.pubads());
    googletag.defineSlot('/3695761/300x250_2', [300, 250], 'div-gpt-ad-1430638724272-3').addService(googletag.pubads());
    googletag.defineSlot('/3695761/728x90', [728, 90], 'div-gpt-ad-1430638724272-4').addService(googletag.pubads());
    googletag.defineSlot('/3695761/728x90_2', [728, 90], 'div-gpt-ad-1430638724272-5').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>


</head>

<body >


<div style="text-align:center; padding-bottom: 5px;">

<center>

<!-- /3695761/728x90 -->
<div id='div-gpt-ad-1430638724272-4' style='height:90px; width:728px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1430638724272-4'); });
</script>
</div>

</center>
</div>

<table id="maintable"><tr><td>
<div id="header">
<a href="/" title="Rajah.com"><img src="/images/rajahheader.jpg" alt="Live WWE RAW Results Now In Progress (4/24): Last RAW Before Payback!" border="0" width="640" height="90" /></a>


</div>
<center>


<!-- /3695761/728x90_2 -->
<div id='div-gpt-ad-1430638724272-5' style='height:90px; width:728px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1430638724272-5'); });
</script>
</div>
<br>
<br></center>

<table id="centertable" cellspacing="10"><tr>

<td valign="top"><div id="menu">
<img src="/images/bartopleft.gif" height="22" width="160" border="0" alt="Menu Image" />
<ul>
 <li>Sections:
        <ul>
                		<li><a href="http://rajah.com">Rajah.com Home</a></li>
<li><a href="https://forums.rajah.com">Forums</a></li>
				<li><a href="http://www.rajah.com/archives/flashbacks/index.php">WWE PPV Flashbacks</a></li>
				<li><a href="http://www.rajah.com/archives/wcwflashbacks/index.php">WCW PPV Flashbacks</a></li>
   <li><a href="http://www.rajah.com/wwf/interactive/mailbag/index.html">Mailbag</a></li>
	        </ul>
 </li>
 <li> Categories:
        <ul>
                		<li><a href="http://www.rajah.com/wrestling/news/">Wrestling News</a></li>
		<li><a href="http://rajah.com/base/taxonomy/term/2">Wrestling Columns</a></li>
		<li><a href="http://rajah.com/base/taxonomy/term/7">Results - House Shows</a></li>
		<li><a href="http://rajah.com/base/taxonomy/term/6">Results - PPV</a></li>
		<li><a href="http://rajah.com/base/taxonomy/term/5">Results - TV</a></li>
		<li><a href="http://rajah.com/base/taxonomy/term/3">Site News</a></li>
		<li><a href="http://rajah.com/aboutus.php">Contact Us</a></li>

        </ul>
 </li>
 <li>Affiliates:
        <ul>    
<li><a href="http://www.ewrestling.com">eWrestling.com</a></li>
<li><a href="http://www.hockeyinformer.com" title="NHL, NFL, MLB, NBA news, discussion and fantasy advice">Hockeyinformer.com</a></li>
</ul>

<br>


<center>
</center>
<br>
<li><hr width="75%" /></li>

</ul>

<br />


<a href="https://twitter.com/RajahNews" class="twitter-follow-button" data-show-count="false">Follow @RajahNews</a>
<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src="//platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script>
<br>
<iframe src="//www.facebook.com/plugins/like.php?href=https%3A%2F%2Fwww.facebook.com%2Frajahwwf&amp;send=false&amp;layout=button_count&amp;width=500&amp;show_faces=false&amp;font=arial&amp;colorscheme=dark&amp;action=like&amp;height=21" scrolling="no" frameborder="0" style="border:none; overflow:hidden; width:500px; height:21px;" allowTransparency="true"></iframe><br>

<br>
<p>
<br>
<br>
<center>
<!-- /3695761/160x600_2 -->
<div id='div-gpt-ad-1430638724272-1' style='height:600px; width:160px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1430638724272-1'); });
</script>
</div>
<p>



</center><p>

</div></td>


<td valign="top"><div id="content">

<div style="text-align:center; padding-bottom: 5px;">



</div>

	
        
        
        
        

<h3 class="storytitle"><a href="/node/55896" title="Live WWE RAW Results Now In Progress (4/24): Last RAW Before Payback!">Live WWE RAW Results Now In Progress (4/24): Last RAW Before Payback!</a></h3>
<div class="meta"><strong>Submitted by Eric Lynch on April 24, 2017 - 7:55pm</strong><br />Posted In: <ul class="links inline"><li class="taxonomy_term_5 first last"><a href="/taxonomy/term/5" rel="tag" title="">Results - TV</a></li>
</ul></div>

<div style="border-top: solid 1px #353535; padding-bottom: 5px;"></div>


<a href="http://rajah.com/node/55895">[Previous Article]</a> - <a href="http://rajah.com/node/">[Back To Rajah.com Main Page]</a> - <a href="http://www.rajah.com/contact">[Contact Author]</a>
<p>
<a href="https://twitter.com/RajahNews" class="twitter-follow-button" data-show-count="false">Follow @RajahNews</a>
<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src="//platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script>
<br>
<iframe src="//www.facebook.com/plugins/like.php?href=https%3A%2F%2Fwww.facebook.com%2Frajahwwf&amp;send=false&amp;layout=button_count&amp;width=500&amp;show_faces=false&amp;font=arial&amp;colorscheme=dark&amp;action=like&amp;height=21" scrolling="no" frameborder="0" style="border:none; overflow:hidden; width:500px; height:21px;" allowTransparency="true"></iframe><br>

<table><tr style="min-height: 400px;"><td>
<div class="content">


<div style="float: right; margin: 5px; border: 0px solid #ccc;">
<center>Sponsored Links</center>
<!-- /3695761/300x250 -->
<div id='div-gpt-ad-1430638724272-2' style='height:250px; width:300px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1430638724272-2'); });
</script>
</div>

<br>




</div>


<p>The April 24th edition of WWE RAW airs live from the Sprint Center Arena in Kansas City, MO on the USA Network and is the final episode before WWE Payback on Sunday. <strong>Keep refreshing this page for live results now in progress!</strong></p>
<p>- This week's broadcast on the USA Network kicks off with a highlight video of Braun Strowman destroying Roman Reigns, Kalisto and others backstage. The video also covers Strowman's match against The Big Show where a big superplex caused the ring to collapse. </p>
<p> We are welcomed to RAW inside the Sprint Center by a big pyro display, and Michael Cole with Corey Graves promoting the "dumpster match" between Braun Strowman and Kalisto. Booker T is filling in for Dave Otunga again tonight. </p>
<p>- Chris Jericho is out to the ring with The List for a new edition of The Hightlight Reel. Jericho says he's going to beat his former friend Kevin Owens on Sunday, and thanks the fans for being his friends. Jericho says Owens' new "face of America" nickname doesn't fit him, and calls him the hemorrhoid of America. The Miz and Maryse interrupt next, and Miz tells the fans to shut their mouths. They get in the ring and tell Chris that "RAW is no longer Jericho." The Miz says he and Maryse are the "it couple" on RAW, and Jericho tells him to "watch........ it." The Miz says The Highlight Reel has been cancelled, and will be replaced with Miz TV. The Miz orders the Highlight Reel set to be taken down, and the Miz TV set to be put up. The Miz beings to welcome everyone to "Miz TV," but he's interrupted by Dean Ambrose. Ambrose tears down the Miz TV set and has his Ambrose Asylum set brought into the ring. Ambrose says he's rooting for Jericho in his match against Owens on Sunday, despite Ambrose's history with Jericho. Jericho reminds Ambrose that he still owes him $15,000 for ruining his jacket. Ambrose says he doesn't have the cash because he lost it playing blackjack, but he has a gift for Jericho. Ambrose presents Jericho with a jacket with Christmas lights stapled to it. Jericho looks like he's about to try it on, but The Miz interrupts and says the jacket looks horrible. Jericho tries it on anyways, and The Miz cuts a promo on him and Ambrose. The Miz says he's the one who should be getting gifts, so Ambrose gives him one: The Dirty Deeds in the middle of the ring. Ambrose leaves, then puts Maryse on The List for being married to a stupid idiot. </p>
<p>- We see Matt and Jeff Hardy backstage getting ready to head to the ring. Matt is in action up next. </p>
<p>- <strong>Matt Hardy def. Sheamus:</strong> Matt attempts a rollup on Sheamus very early, but Sheamus gets out. Hardy hits a swinging neckbreaker on Sheamus and follows up with a series of three leg drops for a two count. They brawl out to the ring apron and Hardy hits the side-effect on Sheamus onto the corner of the apron. Back in the ring, Sheamus mounts a comeback and hits the Ten Beats of the Baron on Matt. Sheamus hits a flying forearm off the top for a near-fall. Matt fires up and hits a clothesline on Sheamus in the corner, followed up by a running bulldog. Matt comes off the middle rope with a flying elbow on Sheamus for a two count. Sheamus hits a knee to the face of Matt and the two men brawl out to ringside. Jeff checks on Matt and Sheamus pushes Jeff away. Jeff gets heated and confronts Sheamus from the apron, then gets in a verbal altercation with Cesaro. Meanwhile in the ring, Sheamus turns around into Matt who hits the Twist of Fate for the win. After the bell, Cesaro confronts Jeff again and blames him for the loss. Sheamus tells Cesaro to calm down, but Cesaro's still heated. Sheamus extends his hand to Matt, then Cesaro extends his to Jeff. They reluctantly shake hands and leave. </p>
<p>- We see Kurt Angle backstage telling someone on the phone that he's going to make sure Kalisto wants to go through with his "dumpster match" against Strowman tonight. The Miz interrupts and complains about Ambrose and Jericho destroying Miz TV earlier. Angle says he doesn't care, and if Miz has a problem he'll have to solve it in the ring. Angle tells Miz to start looking for a partner, because he's going to face both Jericho and Ambrose tonight. Maryse yells at Kurt in French, and Angle tells her "right back at ya." </p>
<p>- <strong>Austin Aries &amp; Jack Gallagher def. Neville &amp; TJ Perkins:</strong> All four men brawl before the bell, with Aries and Gallagher eventually throwing Neville and Perkins to he outside. The match finally officially starts back in the ring and Neville takes control of things against Gallagher early on. Perkins tags in, and before Neville leaves Gallagher drops him into the turnbuckle then throws Perkins into him. Aries gets the hot tag and unloads on Neville and Perkins. Aries hits the pendulum elbow drop on Perkins, then a springboard senton bomb on Neville. Aries throws both Neville and Perkins to the outside and hits a suicide dive on both of them. Aries puts Perkins in the Last Chancery, but Neville breaks it up. Gallagher and Neville mix it up until Gallagher headbutts him down. Aries hits the discus forearm on Perkins for the win. </p>
<p>- The second hour of RAW kicks off with Braun Strowman coming out to the ring. The dumpster is next to the ring, and Strowman starts cutting a promo. He says all of the fans are trash to him, and when he throws Kalisto into the dumpster it'll be just like he's throwing all of the fans and Roman Reigns in there too. </p>
<p>- We cut backstage where Kurt Angle tries to talk Kalisto out of this match. Kalisto says if he doesn't fight for his pride, he doesn't stand for anything. Kalisto heads out to the ramp and Kurt looks impressed. </p>
<p>- <strong>Kalisto def. Braun Strowman:</strong> Kalisto hits some fast kicks on Braun early on. Kalisto hits a spinning jawbreaker on Strowman then heads to the top rope. Kalisto jumps, but Strowman catches him and tosses him across the ring. Strowman picks up Kalisto and heads towards the dumpster, but Kalisto latches on to Strowman and starts trying to pull Strowman over the ropes into the dumpster. Strowman throws Kalisto back into the ring and lays into him with kicks. Strowman hits a running splash on Kalisto in the corner, then hits some more strikes on him. Strowman throws Kalisto towards the dumpster but Kalisto latches onto the ropes. Strowman goes out to the apron with Kalisto and picks him up again. This time Kalisto falls into the ring and dropkicks Strowman's knees out from under him, causing Strowman to fall into the dumpster. Strowman is not happy. Strowman climbs back into the ring and starts stomping on Kalisto. Strowman follows up with a series of chokeslams, then takes Kalisto out to the ringside for more punishment. Strowman throws Kalisto into the fan barricade, then throws him into the dumpster. Strowman closes the dumpster and starts hauling the dumpster up the ramp. Fit Finlay and Jamie Noble come out to try talking Strowman out of doing any more damage, but Strowman chases them off. Strowman ties the dumpster lid shut then shoves the dumpster off the side of the stage. Kalisto gets put in a neck brace and strapped to a stretcher as Michael Cole puts over the fall. We go backstage where Kurt Angle walks with Kalisto as they put him into the ambulance. </p>
<p>- WWE airs a promotional video for Roman Reigns featuring shots of fan signs in favor of Reigns.</p>
<p>- In the latest video from Bray Wyatt, we see more highlights from Orton burning down Wyatt's house. Wyatt says he won't forget what Orton did and some wounds never heal. Wyatt says that "ever room [Orton] enters" in their "House of Horrors" match will be worse than the one before. Wyatt shows illustrations of people being tortured, and continues to warn Orton about the House of Horrors match. </p>
<p>- <strong>Dana Brooke def. Alicia Fox:</strong> Alicia hits a Northern Lights suplex on Dana early on for a two count. Emma comes out to ringside early on during the match. Dana comes back with some clotheslines and a powerslam. Alicia goes for a scissor kick but Dana blocks it and hits a fireman's carry into a piledriver for the win. Emma goes in the ring and hugs Dana after the match, and Dana looks confused. </p>
<p>- Luke Gallows and Karl Anderson are joined by Samoa Joe backstage for an interview. Joe says his strategy is always the same, strike first and annihilate completely. Gallows and Anderson say they've known Joe a long time and have exchanged ideas on how to torture people. Anderson says they have some ideas for how to punish that "butt-nugget" Enzo. Joe adds that he's going to break Rollins for his crimes against Triple H and Stephanie McMahon. </p>
<p>- <strong>Seth Rollins, Enzo Amore &amp; Big Cass vs. Samoa Joe, Luke Gallows &amp; Karl Anderson - No Contest:</strong> Joe, Gallows &amp; Anderson attack Enzo &amp; Cass from behind before the match. Rollins comes out to make the save, and fights off the heels with Cass. Enzo is still down at ringside and referees run out to check on him. Kurt Angle comes out and announces that Enzo is unable to compete tonight, so he'll be replaced by Finn Balor. </p>
<p>- <strong>Seth Rollins, Finn Balor &amp; Big Cass def. Samoa Joe, Luke Gallows &amp; Karl Anderson:</strong> Balor hits the ring and everyone starts brawling before he bell. The ring clears except for Cass and Gallows, so the referee calls for the opening bell. Cass works on Gallows in the corner and hits a running splash. Cass follows up with a fallaway slam on Gallows. Joe and Balor come in and they exchange strikes until Joe drops Balor with a Pele kick. Joe follows up with elbows and headbutts, then tags in Anderson who starts working on Balor's left arm. Anderson hits a backbreaker and tags in Gallows who continues the offense. Gallows superkicks Cass off the apron, then misses a splash on Balor. Balors tags in Rollins who cleans house. Anderson tags in and Rollins hits the Sling Blade. Cass hits a big boot on Gallows that sends both men to ringside. Rollins tosses Anderson outside with Joe and hits a suicide dive on both of them. Balor takes out Joe at ringside, and Rollins hits a flying clothesline on Anderson back in the ring. Rollins looks like he's going for a Pedigree, but he decides against it and hits a knee to the face of Anderson for the win. Joe stares down Rollins after the match. </p>
<p>- Alexa Bliss comes out to the ring and cuts a promo on Bayley. Alexa says she'll take the Women's Title from Bayley on Sunday at Payback, which brings out Bayley to interrupt. Bayley says she knows everyone is trying to take her Women's Championship, but she'll do anything to keep it. Bayley mentions that Payback is in her hometown, and Alexa says she's going to beat her in front of Bayley's family. Alexa says Bayley is a sheltered child and her story is done on Sunday. Sasha Banks interrupts next and calls Alexa a troll doll, and says Bayley will shut her up on Sunday. Sasha says she's going to shut her up tonight, but Alexa says Sasha is out of control and will get their match tonight cancelled. Alexa starts to leave but Sasha stops her with a right hand, and we have a match. </p>
<p>- <strong>Sasha Banks def. Alexa Bliss via countout:</strong> Bayley is on commentary for this one. Alexa gets in lots of offense early on and controls the majority of the opening minutes. Sasha starts to fire up and goes for the Banks Statement, but Alexa quickly reaches the ropes. Alexa rolls outside and appears to be allowing the referee to count her out. Alexa backs up the ramp and the referee counts her out. Alexa starts to head backstage, but Bayley runs up and grabs her. Alexa breaks free and runs off, but then comes back and attacks Bayley from behind. Sasha starts running up the ramp and Alexa runs away again. </p>
<p>- We go backstage where Dean Ambrose is requesting to be taken off of Chris Jericho's list. Jericho says no one gets removed from the list, and that Ambrose not only still owes him $15,000, but Ambrose also slammed him into thumbtacks. Ambrose promises he won't do it again, and Jericho admits that he does like the homemade jacket Ambrose gave him. Jericho says that due to Ambrose's peace offering, he just un-made The List. Ambrose walks off and Jericho appears to add him back to The List. </p>
<p><strong>Keep refreshing this page for live results now in progress!</strong></p>

<!--ad-->
<br>
<center>
<!-- /3695761/300x250_2 -->
<div id='div-gpt-ad-1430638724272-3' style='height:250px; width:300px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1430638724272-3'); });
</script>
</div>

</center>


<br>
<blockquote><li><b><a href="http://www.ewrestling.com" target="new">eWrestling.com: WWE News, Spoilers, Results and more</a></blockquote>
</b>
</div>
</td></tr></table><br />



</div></td>

<td valign="top"><div id="adspacevertical">
<img src="/images/bartop.gif" height="12" width="160" border="0" alt="Menu Image" />
<center><br>
<font color="white">Search rajah.com:</font>
<form action="http://www.google.ca" id="cse-search-box">
  <div>
    <input type="hidden" name="cx" value="partner-pub-9066800762292219:0934435053" />
    <input type="hidden" name="ie" value="UTF-8" />
    <input type="text" name="q" size="15" />
    <input type="submit" name="sa" value="Search" />
  </div>
</form>

<script type="text/javascript" src="http://www.google.ca/coop/cse/brand?form=cse-search-box&amp;lang=en"></script>

<br>
<br>
<p>
<br>
<br>
<br>
<br>
<br>
<br>
<br>
<br>
<br>
<br>
<br>
<br>
<br>
<br>
<br>
<br>

<center>

<!-- /3695761/160x600 -->
<div id='div-gpt-ad-1430638724272-0' style='height:600px; width:160px;'>
<script type='text/javascript'>
googletag.cmd.push(function() { googletag.display('div-gpt-ad-1430638724272-0'); });
</script>
</div>


</center>










</center>
<hr width="75%" /><br /></div></td>

</tr></table>

</td></tr></table>

<p class="credit"><cite>&copy; 1997 - 2017 Rajah.com || <a href="http://www.rajah.com/aboutus.php"><strong>Contact Us</strong></a> || <a href="/privacy.php"><strong>Privacy Policy</strong></a></cite></p>
<center>
<font size="1">This site uses cookies to deliver its services, to personalize ads and to analyze traffic. Information about your use of this site is shared with its partners. By using this site, you agree to its use of cookies.  For details, click <a href="http://rajah.com/privacy.php">here</a>.</font>

<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-29213098-1', 'auto');
  ga('require', 'displayfeatures');
  ga('send', 'pageview');

</script>

</center>





</body>
</html>

